diff mcabber/configure.ac @ 1300:0d4a1699accb

Add OTR check to autoconf
author Mikael Berthe <mikael@lilotux.net>
date Thu, 30 Aug 2007 00:57:07 +0200
parents eb38963e082f
children 887f8801418c
line wrap: on
line diff
--- a/mcabber/configure.ac	Thu Aug 30 00:52:51 2007 +0200
+++ b/mcabber/configure.ac	Thu Aug 30 00:57:07 2007 +0200
@@ -113,6 +113,18 @@
         [Define if you use GPGME to support OpenPGP]))
 fi
 
+# Check for otr
+AC_ARG_ENABLE(otr, [  --enable-otr            Enable OTR (Off-the-Record) messaging support],
+              enable_otr=$enableval, otr="")
+if test "x$enable_otr" = "xyes"; then
+  # Look for libgcrypt and libotr
+  AM_PATH_LIBGCRYPT(1.2.2, [
+          AM_PATH_LIBOTR(3.1.0, ,
+                         AC_MSG_ERROR(libotr 3.1.0 or newer is required.))
+      ], AC_MSG_ERROR(libgcrypt 1.2.2 or newer is required.)
+  )
+fi
+
 AC_ARG_WITH(ssl, [  --with-ssl              enable SSL secured connections using either OpenSSL
                           or GnuTLS],
         [with_ssl=$withval])