diff mcabber/configure.ac @ 1179:0f7e0346d9cb

Add aspell support [Note: Patch slightly modified by Mikael]
author entragian <entragian@o2.pl>
date Wed, 04 Apr 2007 23:23:37 +0200
parents 36450491b884
children 56f7f504b4ba
line wrap: on
line diff
--- a/mcabber/configure.ac	Wed Apr 04 22:43:47 2007 +0200
+++ b/mcabber/configure.ac	Wed Apr 04 23:23:37 2007 +0200
@@ -152,6 +152,24 @@
     fi
 fi
 
+# Check for Aspell stuff
+AC_ARG_ENABLE(aspell, [  --enable-aspell         Enable aspell support],
+              enable_aspell=$enableval, aspell="")
+if test "x$enable_aspell" = "xyes"; then
+    AC_CHECK_HEADERS(aspell.h, [ have_aspell_includes=yes ])
+    if test "x$have_aspell_includes" = "xyes"; then
+        AC_CHECK_LIB(aspell, new_aspell_config, [ have_aspell_libs=yes ])
+        if test "x$have_aspell_libs" = "xyes"; then
+            AC_DEFINE(WITH_ASPELL, 1, [define if you want aspell support])
+            LIBS="$LIBS -laspell"
+        else
+            enable_aspell=no
+        fi
+    else
+        enable_aspell=no
+    fi
+fi
+
 AC_DEFINE(BUILD_JABBER, 1, [build with jabber support])
 
 # Export $datadir to the source tree.