diff mcabber/configure.ac @ 800:103764a87777

Improve autoconf - Check for strcasestr() - Check for tm_gmtoff - Use ACLOCAL_AMFLAGS so that autoreconf works correctly
author Mikael Berthe <mikael@lilotux.net>
date Mon, 10 Apr 2006 23:16:12 +0200
parents 7f10b84ba7fc
children 8c45ec4bf9bc
line wrap: on
line diff
--- a/mcabber/configure.ac	Sun Apr 09 10:18:33 2006 +0200
+++ b/mcabber/configure.ac	Mon Apr 10 23:16:12 2006 +0200
@@ -29,6 +29,7 @@
 AC_CHECK_HEADERS([arpa/inet.h fcntl.h locale.h netdb.h netinet/in.h stddef.h \
                   stdlib.h string.h strings.h sys/socket.h sys/time.h \
                   syslog.h termios.h unistd.h ncurses.h panel.h getopt.h])
+AC_VAR_TIMEZONE_EXTERNALS
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_HEADER_STDBOOL
@@ -49,7 +50,10 @@
 AC_FUNC_VPRINTF
 AC_CHECK_FUNCS([alarm bzero gethostbyname gethostname inet_ntoa isascii \
                 memmove memset modf select setlocale socket strcasecmp \
-                strchr strdup strncasecmp strrchr strstr])
+                strchr strdup strncasecmp strrchr strstr strcasestr])
+
+# Check for tm_gmtoff
+MC_TM_GMTOFF
 
 # Check for glib
 AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR([glib is required]),[g_list_append])