diff mcabber/configure.ac @ 73:1fc66b6c08ef

[/trunk] Changeset 87 by mikael * Check for glib and update Makefiles to use it.
author mikael
date Sat, 16 Apr 2005 11:59:26 +0000
parents c5a5707f495d
children e44dd43e7a69
line wrap: on
line diff
--- a/mcabber/configure.ac	Sat Apr 16 10:14:55 2005 +0000
+++ b/mcabber/configure.ac	Sat Apr 16 11:59:26 2005 +0000
@@ -2,7 +2,7 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ(2.59)
-AC_INIT(mcabber, 0.6.0-dev, bmikael@lists.lilotux.net)
+AC_INIT([mcabber],[0.6.0-dev],[bmikael@lists.lilotux.net])
 AM_INIT_AUTOMAKE
 AC_CONFIG_SRCDIR([src])
 AC_CONFIG_HEADER(config.h)
@@ -43,6 +43,9 @@
 AC_FUNC_VPRINTF
 AC_CHECK_FUNCS([alarm bzero gethostbyname gethostname inet_ntoa isascii memmove memset modf select setlocale socket strcasecmp strchr strdup strncasecmp strrchr strstr])
 
+# Check for glib
+AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR([glib is required]),[g_list_append])
+
 AC_ARG_WITH(ssl, [  --with-ssl              enable SSL secured connections using either OpenSSL
 			  or GnuTLS],
 	[with_ssl=$withval])