diff mcabber/mcabber/Makefile.am @ 1941:2256d0626730

Modularize fifo system (Myhailo Danylenko) Merge patch from isbear's mcabber-experimental repository.
author Mikael Berthe <mikael@lilotux.net>
date Sun, 27 Feb 2011 17:42:27 +0100
parents 668657be02ba
children e8f2db654e67
line wrap: on
line diff
--- a/mcabber/mcabber/Makefile.am	Sun Feb 27 17:24:11 2011 +0100
+++ b/mcabber/mcabber/Makefile.am	Sun Feb 27 17:42:27 2011 +0100
@@ -7,7 +7,7 @@
 		  xmpp.c xmpp.h xmpp_helper.c xmpp_helper.h xmpp_defines.h \
 		  xmpp_iq.c xmpp_iq.h xmpp_iqrequest.c xmpp_iqrequest.h \
 		  xmpp_muc.c xmpp_muc.h xmpp_s10n.c xmpp_s10n.h \
-		  caps.c caps.h fifo.c fifo.h help.c help.h
+		  caps.c caps.h help.c help.h
 
 if OTR
 mcabber_SOURCES += otr.c otr.h nohtml.c nohtml.h
@@ -53,6 +53,8 @@
 endif
 
 mcabberincludedir = $(includedir)/mcabber
+else
+mcabber_SOURCES += fifo.c fifo.h
 endif
 
 #SUBDIRS =