diff mcabber/configure.ac @ 1521:33f8f795abd2

Check for regex support in glib This is needed for the "url_regex" option.
author Mikael Berthe <mikael@lilotux.net>
date Tue, 30 Sep 2008 19:50:46 +0200
parents 1eb27a3bb457
children da91b601bc77
line wrap: on
line diff
--- a/mcabber/configure.ac	Tue Sep 30 09:05:05 2008 +0200
+++ b/mcabber/configure.ac	Tue Sep 30 19:50:46 2008 +0200
@@ -130,6 +130,12 @@
 # Check for glib
 AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR([glib is required]),[g_list_append])
 
+# Check for regex support in glib
+AM_PATH_GLIB_2_0(2.14.0,
+                 AC_DEFINE(HAVE_GLIB_REGEX, 1,
+                           [Define if your glib2 version has regex support]), ,
+                 [g_regex_new])
+
 # Check for gpgme
 AC_ARG_ENABLE(gpgme, AC_HELP_STRING([--disable-gpgme], [disable GPGME support]),
     [ if test x"$enableval" = x"no"; then