diff mcabber/configure.ac @ 2150:392cf37d5966

Get rid of the libgcrypt explicit dependency Libotr depends on libgcrypt, but mcabber itself does not, so we don't have to check for it in the configure script. (Reported by Ryan Schmidt.)
author Mikael Berthe <mikael@lilotux.net>
date Sun, 17 Aug 2014 17:47:59 +0200
parents 5150b3bf4c15
children db6ca1e1e082
line wrap: on
line diff
--- a/mcabber/configure.ac	Sun Jul 06 16:09:27 2014 +0200
+++ b/mcabber/configure.ac	Sun Aug 17 17:47:59 2014 +0200
@@ -203,20 +203,16 @@
     enable_otr=$enableval,
     otr="")
 if test "x$enable_otr" = "xyes"; then
-    # Look for libgcrypt and libotr
-    AM_PATH_LIBGCRYPT(1.2.2, [
-        AM_PATH_LIBOTR(4.0.0, [
+    # Look for libotr
+    AM_PATH_LIBOTR(4.0.0, [
+        AC_DEFINE([HAVE_LIBOTR], 1, [Define if you use libotr])
+    ], [
+        AM_PATH_LIBOTR(3.1.0, [
             AC_DEFINE([HAVE_LIBOTR], 1, [Define if you use libotr])
+            AC_DEFINE([HAVE_LIBOTR3], 1, [Define if you use libotr v3])
         ], [
-            AM_PATH_LIBOTR(3.1.0, [
-                AC_DEFINE([HAVE_LIBOTR], 1, [Define if you use libotr])
-                AC_DEFINE([HAVE_LIBOTR3], 1, [Define if you use libotr v3])
-            ], [
-                AC_MSG_ERROR(libotr 3.1.0 or newer is required.)
-            ])
+            AC_MSG_ERROR(libotr 3.1.0 or newer is required.)
         ])
-    ], [
-        AC_MSG_ERROR(libgcrypt 1.2.2 or newer is required.)
     ])
 fi