diff mcabber/configure.ac @ 1668:41c26b7d2890

Install mcabber headers * Change mcabber headers naming scheme * Move 'src/' -> 'mcabber/' * Add missing include <mcabber/config.h>'s * Create and install clean config.h version in 'include/' * Move "dirty" config.h version to 'mcabber/' * Add $(top_srcdir) to compiler include path * Update modules HOWTO
author Myhailo Danylenko <isbear@ukrpost.net>
date Mon, 18 Jan 2010 15:36:19 +0200
parents d9913c1b35e7
children efee21002ffb
line wrap: on
line diff
--- a/mcabber/configure.ac	Tue Feb 02 21:27:26 2010 +0100
+++ b/mcabber/configure.ac	Mon Jan 18 15:36:19 2010 +0200
@@ -4,8 +4,9 @@
 AC_PREREQ(2.59)
 AC_INIT([mcabber],[0.10.0-dev],[mcabber@lilotux.net])
 AM_INIT_AUTOMAKE
-AC_CONFIG_SRCDIR([src])
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_SRCDIR([mcabber])
+AM_CONFIG_HEADER(mcabber/config.h)
+#AC_CONFIG_HEADER(include/config.h)
 
 #AC_PROG_LIBTOOL
 AC_PROG_RANLIB
@@ -253,11 +254,12 @@
 fi
 
 AM_CONDITIONAL([OTR], [test x$libotr_found = xyes])
+AM_CONDITIONAL([INSTALL_HEADERS], [test x$enable_modules = xyes])
 
 # We need _GNU_SOURCE for strptime() and strcasestr()
 CFLAGS="$CFLAGS -D_GNU_SOURCE"
 
-AC_CONFIG_FILES([src/Makefile
+AC_CONFIG_FILES([mcabber/Makefile
                  doc/Makefile
                  doc/guide/Makefile
                  doc/help/Makefile