diff mcabber/mcabber/Makefile.am @ 1735:5093b5ca1572

New modules loading scheme
author Myhailo Danylenko <isbear@ukrpost.net>
date Thu, 04 Mar 2010 13:03:20 +0200
parents 41c26b7d2890
children e7ce50fe19a9
line wrap: on
line diff
--- a/mcabber/mcabber/Makefile.am	Tue Mar 02 13:47:43 2010 +0100
+++ b/mcabber/mcabber/Makefile.am	Thu Mar 04 13:03:20 2010 +0200
@@ -32,6 +32,7 @@
 endif
 
 if INSTALL_HEADERS
+mcabber_SOURCES += modules.c modules.h
 mcabberinclude_HEADERS = main.h roster.h events.h \
 			 commands.h compl.h \
 			 hbuf.h screen.h logprint.h \
@@ -40,7 +41,8 @@
 			 xmpp.h xmpp_helper.h xmpp_defines.h \
 			 xmpp_iq.h xmpp_iqrequest.h \
 			 xmpp_muc.h xmpp_s10n.h \
-			 caps.h fifo.h help.h $(top_srcdir)/include/config.h
+			 caps.h fifo.h help.h modules.h \
+			 $(top_srcdir)/include/config.h
 
 if OTR
 mcabberinclude_HEADERS += otr.h nohtml.h