diff mcabber/configure.ac @ 1712:7bdd9ed28684

Add .pc file
author Myhailo Danylenko <isbear@ukrpost.net>
date Mon, 08 Feb 2010 00:32:18 +0200
parents 96b5484423af
children e2c6f1357f82
line wrap: on
line diff
--- a/mcabber/configure.ac	Tue Feb 09 18:05:13 2010 +0100
+++ b/mcabber/configure.ac	Mon Feb 08 00:32:18 2010 +0200
@@ -262,11 +262,21 @@
 # We need _GNU_SOURCE for strptime() and strcasestr()
 CFLAGS="$CFLAGS -D_GNU_SOURCE"
 
+EXTRA_REQUIRES=""
+if test "$enable_enchant" = "yes"; then
+    EXTRA_REQUIRES="$EXTRA_REQUIRES enchant"
+fi
+if test "$enable_gpgme" != "no"; then
+    EXTRA_REQUIRES="$EXTRA_REQUIRES gpgme"
+fi
+AC_SUBST([EXTRA_REQUIRES])
+
 AC_CONFIG_FILES([mcabber/Makefile
                  modules/Makefile
                  modules/beep/Makefile
                  doc/Makefile
                  doc/guide/Makefile
                  doc/help/Makefile
+                 mcabber.pc
                  Makefile])
 AC_OUTPUT