diff mcabber/src/Makefile.am @ 113:8ac67e951eab

[/trunk] Changeset 127 by mikael * Add a "hooks" layer. Hooks are used when multiples operations should be done when an event araises. For example message in/out, status change... 2 more files; Makefile updated. * Logging is ready. * Add 2 options: - "logging" (bool): enable/disable history logging - "logging_dir" (char): root dir for logging files * Document pinginterval (keepalive) in the sample config file. * Send keepalive only when online.
author mikael
date Sun, 24 Apr 2005 20:24:18 +0000
parents 3d41aca3d878
children ef898db62b79
line wrap: on
line diff
--- a/mcabber/src/Makefile.am	Sun Apr 24 17:38:48 2005 +0000
+++ b/mcabber/src/Makefile.am	Sun Apr 24 20:24:18 2005 +0000
@@ -3,7 +3,7 @@
 		  commands.c commands.h compl.c compl.h \
 		  hbuf.c hbuf.h screen.c screen.h \
 		  parsecfg.c parsecfg.h utf8.c utf8.h \
-		  histolog.c histolog.h \
+		  hooks.c hooks.h histolog.c histolog.h \
 		  utils.c utils.h lang.c lang.h list.h harddefines.h
 
 LDADD = -lglib-2.0 -lncurses -lpanel -lssl \