diff mcabber/configure.ac @ 1386:8e763c2c331f

Add option 'escdelay' This option overrides the environment variable. The autoconf check for ESCDELAY was borrowed from the Midnight Commander project.
author Mikael Berthe <mikael@lilotux.net>
date Sun, 02 Dec 2007 17:56:51 +0100
parents 1447c5296977
children 40371a7d49f4
line wrap: on
line diff
--- a/mcabber/configure.ac	Sun Dec 02 17:16:09 2007 +0100
+++ b/mcabber/configure.ac	Sun Dec 02 17:56:51 2007 +0100
@@ -102,6 +102,20 @@
     AC_MSG_WARN([Your ncurses installation does not support unicode])
 fi
 
+AC_CACHE_CHECK([for ESCDELAY variable],
+               [mc_cv_ncurses_escdelay],
+               [AC_TRY_LINK([], [
+                            extern int ESCDELAY;
+                            ESCDELAY = 0;
+                            ],
+                            [mc_cv_ncurses_escdelay=yes],
+                            [mc_cv_ncurses_escdelay=no])
+               ])
+if test "$mc_cv_ncurses_escdelay" = yes; then
+    AC_DEFINE(HAVE_ESCDELAY, 1,
+              [Define if ncurses has ESCDELAY variable])
+fi
+
 # Check for glib
 AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR([glib is required]),[g_list_append])