diff mcabber/configure.ac @ 1426:a64778f5f26b

Implement FIFO named command pipe
author Mikael Berthe <mikael@lilotux.net>
date Mon, 18 Feb 2008 22:59:37 +0100
parents 757ebe4df0b9
children 844410b9b4cc
line wrap: on
line diff
--- a/mcabber/configure.ac	Sun Feb 17 21:19:58 2008 +0100
+++ b/mcabber/configure.ac	Mon Feb 18 22:59:37 2008 +0100
@@ -227,10 +227,18 @@
     CFLAGS="-O2 $CFLAGS"
 fi
 
+AC_ARG_ENABLE(fifo,
+    [AC_HELP_STRING(--enable-fifo, Enable FIFO named pipe)],
+    fifo=$enableval, fifo="")
+AM_CONDITIONAL([FIFO], [test x$fifo = xyes])
+if test x"${fifo}" = x"yes"; then
+    AC_DEFINE_UNQUOTED([ENABLE_FIFO],[1],[Named pipe support])
+fi
+
 AC_ARG_ENABLE(hgcset,
     [AC_HELP_STRING(--disable-hgcset, Do not use Mercurial changeset value)],
     hgcset=$enableval, hgcset="yes")
-AM_CONDITIONAL(HGCSET, test x$hgcset = xyes)
+AM_CONDITIONAL(HGCSET, [test x$hgcset = xyes])
 if test "${hgcset}" = "yes"; then
     AC_DEFINE(ENABLE_HGCSET, 1, [Use Mercurial changeset])
 fi