diff mcabber/configure.ac @ 868:cefdaeb42e67

Add online /help command We use help files stored in "$DATA_DIR/mcabber/help/$lang/", with $lang defaulting to "en". The DATA_DIR location can be set using configure --with-datadir="...".
author Mikael Berthe <mikael@lilotux.net>
date Thu, 25 May 2006 18:20:52 +0200
parents 8c64874c449e
children b38760d9ec2d
line wrap: on
line diff
--- a/mcabber/configure.ac	Wed May 24 23:30:31 2006 +0200
+++ b/mcabber/configure.ac	Thu May 25 18:20:52 2006 +0200
@@ -113,6 +113,13 @@
 
 AC_DEFINE(BUILD_JABBER, 1, [build with jabber support])
 
+AC_ARG_WITH(datadir,
+    [AC_HELP_STRING(--with-datadir, Read-only data (help files))],
+    datadir=$withval, datadir="")
+if test x"${datadir}" != x""; then
+    AC_DEFINE_UNQUOTED(DATA_DIR, "${datadir}", [Data files directory])
+fi
+
 AC_ARG_ENABLE(debug,
     [AC_HELP_STRING(--enable-debug, Add development compilation options)],
     debug=$enableval, debug="")