diff mcabber/src/Makefile.am @ 1309:887f8801418c

Only compile otr.c if libotr is available
author franky@veqlargh.fs
date Mon, 10 Sep 2007 19:52:43 +0200
parents 0d4a1699accb
children a64778f5f26b
line wrap: on
line diff
--- a/mcabber/src/Makefile.am	Mon Sep 10 19:52:14 2007 +0200
+++ b/mcabber/src/Makefile.am	Mon Sep 10 19:52:43 2007 +0200
@@ -5,7 +5,11 @@
 		  hbuf.c hbuf.h screen.c screen.h logprint.h \
 		  settings.c settings.h hooks.c hooks.h utf8.c utf8.h \
 		  histolog.c histolog.h utils.c utils.h pgp.c pgp.h \
-		  otr.c otr.h help.c help.h
+		  help.c help.h
+
+if OTR
+mcabber_SOURCES += otr.c otr.h
+endif
 
 LDADD = $(GLIB_LIBS) $(GPGME_LIBS) $(LIBOTR_LIBS) \
 	../libjabber/liblibjabber.a ../connwrap/libconnwrap.a