diff mcabber/configure.ac @ 1040:b6c6734a781b

Add libgpgme detection
author Mikael Berthe <mikael@lilotux.net>
date Sun, 26 Nov 2006 10:14:47 +0100
parents f79e6d3d7190
children a61c3311a5bb
line wrap: on
line diff
--- a/mcabber/configure.ac	Thu Nov 23 21:47:20 2006 +0100
+++ b/mcabber/configure.ac	Sun Nov 26 10:14:47 2006 +0100
@@ -92,6 +92,18 @@
 # Check for glib
 AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR([glib is required]),[g_list_append])
 
+# Check for gpgme
+AC_ARG_ENABLE(gpgme, AC_HELP_STRING([--disable-gpgme], [Disable GPGME support]),
+    [ if test x"$enableval" = x"no"; then
+        enable_gpgme=no
+      fi
+    ])
+
+if test x"${enable_gpgme}" != x"no"; then
+    AM_PATH_GPGME(1.0.0, AC_DEFINE(HAVE_GPGME, 1,
+        [Define if you use GPGME to support OpenPGP]))
+fi
+
 AC_ARG_WITH(ssl, [  --with-ssl              enable SSL secured connections using either OpenSSL
                           or GnuTLS],
         [with_ssl=$withval])
@@ -141,7 +153,7 @@
 AC_ARG_ENABLE(debug,
     [AC_HELP_STRING(--enable-debug, Add development compilation options)],
     debug=$enableval, debug="")
-if test "${debug}" = "yes"; then
+if test x"${debug}" = x"yes"; then
     AC_DEFINE_UNQUOTED([DEBUG_ENABLE],[1],[Devel compilation options])
     if test "x$GCC" = "xyes"; then
         if test "$gccvernum" -ge "400"; then