diff mcabber/configure.ac @ 1454:6b98dc22946d

Add optional SIGWINCH handler (Markus Hennecke) This patch from Markus Hennecke adds a configure option to provide a SIGWINCH handler. It is useful on some systems like OpenBSD where there is no default handler for this signal.
author Mikael Berthe <mikael@lilotux.net>
date Thu, 03 Apr 2008 21:20:56 +0200
parents 844410b9b4cc
children 5e99e802656c
line wrap: on
line diff
--- a/mcabber/configure.ac	Wed Apr 02 22:31:23 2008 +0200
+++ b/mcabber/configure.ac	Thu Apr 03 21:20:56 2008 +0200
@@ -67,6 +67,16 @@
 # Check for tm_gmtoff
 MC_TM_GMTOFF
 
+# Check if we must provide a SIGWINCH handler
+AC_ARG_ENABLE(sigwinch,
+        [  --enable-sigwinch       compile with SIGWINCH handler],
+        [with_sigwinch=$enableval],
+        [with_sigwinch=$with_ext_funcs])
+AC_MSG_RESULT($with_sigwinch)
+if test "$with_sigwinch" = yes; then
+    AC_DEFINE(USE_SIGWINCH, [], [Provide own SIGWINCH handler])
+fi
+
 # Checks for libraries.
 
 AC_CHECK_LIB(charset, locale_charset)