diff mcabber/configure.ac @ 881:618967a008a2

Try to fix autoconf setup
author Mikael Berthe <mikael@lilotux.net>
date Sat, 27 May 2006 17:35:19 +0200
parents b38760d9ec2d
children c3c2f7a0c5d5
line wrap: on
line diff
--- a/mcabber/configure.ac	Sat May 27 15:59:05 2006 +0200
+++ b/mcabber/configure.ac	Sat May 27 17:35:19 2006 +0200
@@ -115,7 +115,9 @@
 
 # Export $datarootdir to the source tree.
 if test x"${datarootdir}" != x""; then
-    AC_DEFINE_UNQUOTED(DATA_ROOT_DIR, "${datarootdir}", [Data files directory])
+    AC_DEFINE_DIR(DATA_ROOT_DIR, "${datarootdir}", [Data files directory])
+elif test x"${datadir}" != x""; then
+    AC_DEFINE_DIR(DATA_ROOT_DIR, "${datadir}", [Data files directory])
 fi
 
 AC_ARG_ENABLE(debug,