diff mcabber/configure.ac @ 877:b38760d9ec2d

autoconf: Remove --with-datadir, use built-in --datarootdir option
author Mikael Berthe <mikael@lilotux.net>
date Sat, 27 May 2006 12:51:19 +0200
parents cefdaeb42e67
children 618967a008a2
line wrap: on
line diff
--- a/mcabber/configure.ac	Sat May 27 00:05:17 2006 +0200
+++ b/mcabber/configure.ac	Sat May 27 12:51:19 2006 +0200
@@ -113,11 +113,9 @@
 
 AC_DEFINE(BUILD_JABBER, 1, [build with jabber support])
 
-AC_ARG_WITH(datadir,
-    [AC_HELP_STRING(--with-datadir, Read-only data (help files))],
-    datadir=$withval, datadir="")
-if test x"${datadir}" != x""; then
-    AC_DEFINE_UNQUOTED(DATA_DIR, "${datadir}", [Data files directory])
+# Export $datarootdir to the source tree.
+if test x"${datarootdir}" != x""; then
+    AC_DEFINE_UNQUOTED(DATA_ROOT_DIR, "${datarootdir}", [Data files directory])
 fi
 
 AC_ARG_ENABLE(debug,